HPC:Java

From PMACS HPC
Jump to: navigation, search

OpenJDK 1.6.0, 1.7.0 and 1.8.0 have been installed on all nodes. The default is 1.6.0. If you want to set 1.7.0 or 1.8.0 as the default version of java, use either the `java-sdk-1.7.0` or `java-sdk-1.8.0` environment module

[asrini@node077 ~]$ module load java-sdk-1.7.0

[asrini@node077 ~]$ java -version
java version "1.7.0_71"
OpenJDK Runtime Environment (rhel-2.5.3.1.el6-x86_64 u71-b14)
OpenJDK 64-Bit Server VM (build 24.65-b04, mixed mode)
[asrini@node077 ~]$ module load java-sdk-1.8.0

[asrini@node077 ~]$ java -version
openjdk version "1.8.0_131"
OpenJDK Runtime Environment (build 1.8.0_131-b11)


Other Pages